The B.O.M. Tool, Symbols, and Graphite

Section One : Basic BOM Table Creation

/ During the course of your work as a draftsman, engineer, or designer you migh\

ask , “How do I use the B.O.M. Tool in Graphite?”, or “Is it possible to define a generic
part in Graphite and have it retain BOM attributes?”. You may not know it, but Graphite
comes with BOM tools and Symbol Tools.

If you’re a former AutoCAD user you’ll soon find out how you can avoid
defining a block and manually building a BOM on your prints. If you’re new to
Graphite, this tutorial will give you a head start in streamlining workflow. These tools
can help maximize efficiency no matter what your drafting background.

Without further exposition, let’s dive in and get started!

*NOTE: Set your View AND Plane to Top at this time. All work is performed in the Top
View and Top Plane unless otherwise specified.

**NOTE: If you have not already done so, read the Graphite Bom Read.me file now. It
contains imnortant set-un information for successtullv comnletine this tutorial.
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You should now see the dialogue box shown
X
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What we have done is given our BOM a Layout where all its information can be stored.
If needed, we can define multiple Layouts to handle different BOM tables. For now, we’ll stick
with a single Layout to keep it simple.




Now we must define the columns that we want in our BOM table. These will have
names like Description, Manufacturers Part Number, Quantity, and Material. These

“columns” are known as Attributes in Graphite.

—

Select Text> Bill Of Materials >
Define Attributes. You’ll now see the
dialog pictured here.
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Pay close attention to these next few steps.

It is imperative that your BOM attributes be set

up correctly now. If they are not you’ll have to come back and re-define the attributes.
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Click on the Attribute 1 title in the
dialog box so that it highlights.
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Now highlight the phrase Attribute 1
located in the Attribute Name field.
Drag your cursor across the word(s)

to highlight them. Type in Description.
This is what you should see.
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Highlight the word Default located in the
Default Value field. Delete the word and
leave it blank. Hit the Redefine button
(this is very important, otherwise your
attribute will not “take”). The dialog box
should now look like the on pictured here.
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Now we must define the other Attributes we want in our BOM. We will create the
following Attributes by repeating the previous steps.

e Mfr Part No.
e Manufacturer
e Material

e  Quantity

With the Attributes dialog box still open,

click on the New button. Now you get a new
Attribute I in your dialog box like the one shown.
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Attribute Name; |Atlrihute 1

Default Yalue: |Defaulll

Create Mfr Part No., Manufacturer, and the Material attributes using the same steps we used to create
the Description attribute. When you’ve accomplished that move on to the next step(s) to learn how to

create the Quantity attribute.

Defining the Quantity attribute differs only slightly from the others. If you were

looking at the other buttons in the dialog box you may have been wondering what that
Text dropdown menu does. Look at the screenshot below for clarification.
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Click on the dropdown menu Text to expand it.

Here’s what it will look like.
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This dropdown menu allows you to define the type of information that an attribute
can hold. For example , if you define an attribute as a Number type you won’t be able to
input anything other than numbers. Here’s an explanation of what each type does . . .

Text : Allows a BOM attribute to hold alphanumeric information including some
special characters such as dashes (- ). EX. Valex 123.10

Number: Choosing this type will force a BOM attribute to accept only numbers.
EX. 1234554321, 1.234

Qty.: This type allows you to set how many parts are needed per print.
By defining a BOM attribute type as Qty., the program will automatically count
how many times geometry occurs on a drawing. This only applies if geometry has
a BOM attribute with a Qty. type. The majority of Qty attributes will have a
Default Value of 1.
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dropdown menu and change the attribute type to Qty.
Make sure to click the Redefine button. Your dialog | = Attribute Name: |Quantity
Box should look like the one shown here. Default Value: |1

STOP: Very Important! Go to Layout > Preferences> Save Preferences
RIGHT NOW!

After you have set-up and defined the Layout and BOM Attributes, you MUST
save your preferences. This cannot be stressed enough. If this step is not performed,
the next time you open Graphite all the BOM information will be lost. Now close and
re-open Graphite. You should have a blank page open.




Now we are ready to apply these attributes to some geometry and have Graphite create a
BOM table for our drawing(s).

Provided with this tutorial is a file for you to work with. It is called chalice.vc6. Import
this file onto your blank page. Follow these steps to Import the file properly.

1) Go File>Import

2) Browse to where the file is saved. It should have been saved to your desktop.
3) Select the file named chalice.ve6 and click the Open button.

4) The Import type dialog will appear.

5) Set the Import type to Graphite.

6) Click OK

/ Why is it necessary to Import this file? \

Graphite cannot assign a BOM layout or BOM attributes to files that were
created lacking these important features. The chalice.vc6 file was created “naked”,
or in other words; it was drafted without a BOM Layout or BOM Attributes
assigned to it. So when a File>Open is performed it is opened without any of the
BOM settings. However, when we Import the file Graphite will automatically
force the file to accept the BOM Layout and BOM Attributes: provided that they
have been created beforehand. As a general rule, import the file to ensure BOM
settings are applied.

- /

If the drawing does not show up on your page perform a Zoom All by pressing CTRL+F
on the PC , or Command-+F on the Mac. Your screen should look like this . . .

Your dimensions may appear slightly differently depending on the precision and
tolerances set in the Dimensions menu.
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Click in blank space to deselect the geometry in the chalice.vc6 file.

v ri3.754>!

)

0.234

120°

v

A

Z2.93

B |

A A A

430484

Y

5.484

D722

Select Text>Bill Of Materials>
Show Palette. A new toolbar will
appear near the upper left-hand

corner of your screen. This is the BOM

tool palette.
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We are now going to apply the BOM Attributes we defined earlier to some of the

on-screen geometry. Our initial set-up is going to be wrong, but we are going to do
this for good reason. It will demonstrate a very important point about how Graphite
assigns a QTY type attribute to geometry.




[# Selection Mask

Go Edit>Selection Mask. A dialog box will
appear. Hold down the CTRL key
(COMMAND key on the Mac) and set it so
that the middle column of the dialog box
highlights ONLY CENTERLINES,

CHALICE FLANGE, and HIDDEN
LINES.

*#* You may have an extra layer called
Forms. Make sure it is not selected. ***
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Now press CTRL+A (COMMAND+A on
Mac) and all the geometry except the
dimensions should highlight.

Select the first tool in the BOM tool palette;
the User Attribute Tool. Your cursor will
change to an arrow with the letter “A” by it.
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Hold down the your right-mouse button(or just hold down your mouse if you use
a single button Mac mouse) and drag a selection fence around the entire drawing.
Because we took the time to set up our Selection Mask, only the part geometry, hidden
lines, and centerlines should highlight. But something else happens, too. Look down at
the bottom of your screen. You should see all the BOM Attributes you defined at the
beginning of this tutorial appear. Next to each attribute should be a blank data field. Here
is where we type in the specific BOM information we want to see on our print.

1| Description | | M. Part Mo, | | Manufacturer | | b aterial [ | Guantity [1

Type the following information into the database fields . . .
Description: Chalice Flange

Mfr. Part No.: 12345-001

Manufacturer: HPS Inc.

Material: 304SS

Quantity: | (STOP! AFTER YOU TYPE IN “1” HERE PRESS
THE ENTER KEY (RETURN ON THE MAC)!)

If you do not perform this action the BOM Attributes will not be applied and you
will get a blank BOM Table.

The next step is to place a BOM Table on the drawing =
that will display the BOM Attributes we entered for each '-._'A
of those fields. Start by selecting the last tool in the

BOM Tool Palette. This is called ,aptly enough, BOM Tool.
Your cursor will change to look like a chart or
spreadsheet icon.
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Using the Drafting Assistant, move your cursor to the top of the part centerline.
The Drafting Assistant should “wake up” the endpoint. Move down along the centerline.
The word “on” should appear as you move the cursor. Keep moving down the centerline
until your cursor is about 17-2” below the 2 dimension. Click here. You will now see
that Graphite creates a BOM table for this part at this location. (See picture below for

clarification).
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there’s something fishy about it.

Congratulations! You’ve just created your first Graphite BOM Table. Ych

Take a look at the Quantity column. Notice it

indicates that we have 23 parts for this drawing. We also have no Item # listing. Well,
that can’t be right! We want our BOM to show a quantity of 1. After all , we’ve only
got one part on the print.

Why has this occurred? The answer is simple — because we have assigned our
BOM attributes to each of the 23 lines that make up the geometry. If we want the
BOM Tool to treat this piece as a single entity the geometry MUST be grouped. In
addition, we’ve no Item # because we have not applied a numbered balloon callout to
Qle drawing. Now that we know what’s wrong it’s easy to go back and fix it. /




To fix our BOM,, first close the Selection Mask,
if not already done so. Press CTRL+A
(APPLE+A on the Mac). All geometry

should highlight. We have to do this to

. ’ [HermDescription Mfr. Part NelMdanufdcturerfdaterialQudniity
reset the Selection Mask. We don’t | Chalice Flanqe12345-001 JHPS Inc, 50455 25 |
want to filter out any geometry. Now

pick the Selection Tool and click in an
empty area on the screen to deselect
everything. With the Selection Tool still
active, click on the BOM Table you’ve
just placed. It will highlight. Press the
Delete key and erase the table.

Once we’ve deleted the “bad” BOM
Table , we need to go and access the | 1 |
Selection Mask again. Select Edit> |
Selection Mask. Once again, set
your filters in the middle column |
so that CHALICE FLANGE,
CENTERLINES, and HIDDEN LINES
are the only items highlighted in that
column. Press CTRL+A (COMMAND+A
on the Mac) to highlight the |
part geometry only. Select Arrange> T
Group. Close the Selection
Mask. Hit CTRL+A
(COMMAND++A on the Mac) to
select everything on-screen and ] |
thereby reset the Selection Mask.
Pick the Selection Tool. Click
anywhere on the part geometry. Only
the part will highlight, even though
we’ve reset the Selection Mask. HL | il
The dimensions will remain unhighlighted.

All part geometry should
highlight after grouping.

< Pick the User Attribute Tool from
[ then BOM Tool Palette.
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Click on any part of the geometry, except for any dimensions. The part
geometry will highlight. Your BOM attributes will also appear at the
bottom of the screen.

4| Description | | bAfr. Part Mo | | b anufacturer | M aterial | Quantity [1

Type in the following data for the fields . . .
Description: Chalice Flange

Mfr. Part No.: 12345-001

Manufacturer: HPS Inc.

Material: 304SS

Quantity: 1 (STOP! AFTER YOU TYPE IN “1” HERE PRESS
THE ENTER KEY (RETURN ON THE MAC)!)

If you do not perform this action the BOM Attributes will not be applied and you
will get a blank BOM Table.

Before we place our corrected BOM Table we need to put a ballooned item number
callout on the part. This ensures that the BOM table will be properly filled out.

From the BOM Tool Palette, select the
Item Number Tool. The cursor will

change into a leader line.
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We can now place a corrected BOM Table on the
Drawing that will display the BOM Attributes, and

the information we entered for each of those

fields. Start by selecting the last tool in the BOM
Tool Palette. Repeat the steps previously performed

to create the corrected BOM Table.

Click once. A ballooned item
number callout will now attach to
the part. Go pick the Selection Tool.
Click in an empty area on-screen

to deselect the item number

balloon. You should have something
like the screenshot at left.
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Using the Drafting Assistant, move your cursor to the top of the part centerline.
The Drafting Assistant should “wake up” the endpoint. Move down along the centerline.
The word “on” should appear as you move the cursor. Keep moving down the centerline
until your cursor is about 1”’-2” below the 2 dimension. Click here. You will now see
that Graphite creates a BOM table for this part. (See picture below for clarification).
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2) Move down along the centerline. The DA should
< say “on”. Keep moving down past the “2”
dimension, the DA will say “Align Y”.
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3) Place the
BOM Table by —
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Congratulations! This completes the BOM creation section of the tutorial.

If you want to learn how to use generic symbols for use across
all of your prints then read on.




Section Two : Creating Generic Symbols With Editable
BOM Attributes

Creating generic symbols in Graphite is a powerful and highly useful feature.
These symbols can help you.. . .

define a parts library

create weld instructions (weld symbols)

implement an industry specific symbols library that is not readily available
update an existing parts library that’s out of date.

streamline workflow

increase productivity

use parametric symbols (see Users Guide for this).

~

/It is highly recommended that you complete the Basic BOM Table Creation section
first. This will give you a good idea of how symbols interact with assigned attributes.
You will also be assured that Graphite is set up with the same terms and specific
BOM references used in this section. If you use your own BOM attributes and/or
Layouts this section can be completed. However, Ashlar Technical Support will not

troubleshoot any problems unless section one has been finished.

\_

)

Defining a symbol with editable BOM attributes works in much the same fashion
as setting up a part for use with a BOM table. The basic steps are the same. It is
necessary to 1) draw the geometry of your part , 2) assign BOM attributes , and 3) place a
BOM table. The manner in which these steps are performed differs.

For brevity’s sake, this tutorial includes the files you’ll need. This will save time
since we won’t have to draw a part from scratch. In addition, we will be using the

Standard BOM layout and its BOM attributes that were defined in section one.

Let’s get started then.




Open a new document in Graphite.

Go File>Import and locate the file

named Symbol-Tutorial-Valve.ve6. Click
Open. The file import type dialog box
will appear. Set the import type to
Graphite, if not already done so. Hit OK.
Press CTRL+A (COMMAND+A

on the Mac). Your screen should

look like the one pictured at right. h /
Pick the Selection Tool. | |
Click on an empty area of the screen
to deselect the drawing.

Let’s assume that we know all the pertinent information about this part. Our objective is to
create it so that we can use it across several prints, drop the part in place, and have it
retain any predefined attribute data we assign to it.

Select Text>Bill Of Materials>

Show Palette. This will place the BOM
Tool palette on the screen. Select the second
tool in the palette. This is the BOM Symbol
Attribute Tool. The cursor will update to
look like a chart or spreadsheet type icon.
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At the screen bottom, the BOM Attributes will appear.

*| Dezcription | | bfr. Part Mo, | | b anufacturer b aterial | | Guantity [1

Input the following information for each BOM attribute field.
Description: 3-Port Valve

Mfr. Part No. : 6LV-DPA-111

Manufacturer : Swagelok

Material : 316SS

Quantity: 1 (STOP! AFTER YOU TYPE IN “1” HERE PRESS
THE ENTER KEY (RETURN ON THE MAC)!)

get a blank BOM Table.

|
midpaint
%}r‘c at “midpoint” here.

&

[ If you do not perform this action the BOM Attributes will not “take” and you will \]

Move your cursor to the top
midpoint of the part geometry.




g . Move cursor off the part along “Align X”
E to this location. Click here once.

N

Move your cursor horizontally to the
right off the geometry until the
Drafting Assistant says Align X.
Click once about 2.5”-3” off the part
while the Align X notation is still

‘ ‘ active.

0 5, |._ Lripute value

Description |[5—Port Valve

f

ar V—DFA—TT1] | Performa Zoom All by pressing
ManufacturerSwagelok CTRL+F (COMMAND-F on the
- S Mac). Your screen should look like




Now go pick the Selection Tool.
Press CTRL+A (COMMAND+A on
The Mac). The drawing and the
attribute table will highlight.

Select File>Save As and save the file on your Desktop as Valve-Symbol.vc6 Close the
Valve-Symbol.vc6 drawing.

We will now place the symbol into an existing print. We’ll need to assign BOM attributes
to the existing geometry. Then we will place a BOM Table on the blueprint. Our objective here
is to demonstrate that even though a symbol will retain BOM attribute information, any other
geometry must have that information assigned to it. This is the only way to ensure that a proper
BOM table is created.

Select File>Import> locate the file named Symbol-Tutorial.vc6. Select this file and
click Open. Set the Import Type to Graphite. Perform a Zoom All. Your screen should
look like the picture below.
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Select File>Symbol. The symbol dialog

box will appear. If the Valve-Symbol.vc6

is not automatically selected click New.
Browse to the file named Valve-Symbol.vc6.
Select the file, and click Open. You should get
something similar to the screenshot at right.

If it was necessary to go locate the file by
clicking the New button, your data fields

won’t be filled out. This is perfectly fine.
The BOM attributes that were previously
assigned to the symbol are still intact.
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chalice.vch
Symbol-Tutorial-¥alve.vch

Symbol-Tutorial.vch
Symbuol-Valve.vch

[File [ New |[Place | [Cancell[ OK 1

Descrintion [3-Port Vah

Mfr. Part No. |GLY-DPA-11
Material (31655

Quantitv [1

Manufacturer [Swaaelok

Move your cursor off the dialog box.
Notice that it changes to a

bulls-eye / crosshairs. Click once
somewhere in the confines of the
drafting border. Then move your cursor
back to the dialog box and click Place.
Close the dialog box. The valve should
be placed within or very close to

the drafting border. If you don’t see it
perform a Zoom All.

The symbol will be selected.

Move the symbol such that the weld
stubs on it fill the gap in the tubing
on the print. Deselect the symbol
by clicking on an empty area on the
screen.
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Before a BOM Table can be placed, it is necessary to assign our BOM attributes to
the non-symbol geometry. Failure to do this will result in an incorrect BOM table. The
reason is because we have filled out the BOM attribute data for the symbol only. The
“tubing” and “elbow” on the print currently possess no attributes.

==| Select Text>Bill Of Materials>Show
EF. Palette.
The BOM Tool palette will display.
[Q Now select the User Attribute Tool.
=]

Hold down the SHIFT key. Click on the
three long rectangles so that they become
highlighted. The BOM attributes will
display at the screen bottom.

Type in the following information for the BOM Attributes . . .
Description: SS Tubing

Mfr. Part No. : 025-LS

Manufacturer : Valex

Material : 316SS

Quantity: 1 (STOP! AFTER YOU TYPE IN “1” HERE PRESS
THE ENTER KEY (RETURN ON THE MAC)!)

If you do not perform this action the BOM Attributes will not “take” and you will
get a blank BOM Table.




Now click on the square that represents
the elbow fitting. Again the BOM
Attributes will appear at the screen
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Type in the following information for the BOM Attributes . . .
Description: /4 Elbow

Mfr. Part No. : 025-EL

Manufacturer : Cajon

Material : 316SS

Quantity: 1 (STOP! AFTER YOU TYPE IN “1” HERE PRESS
THE ENTER KEY (RETURN ON THE MAC)!)

If you do not perform this action the BOM Attributes will not “take” and you will
get a blank BOM Table.

Now go to the BOM Tool Palette and
select the third tool. This is the Item
Number Tool.




Assign an item number balloon to each piece of grouped geometry. If your item

number balloons become non-sequential (i.e.the balloon numbers skip from ,say, 2 to 5)
click on the balloon that is incorrectly numbered to select it. Press CTRL+I (APPLE+I
on the Mac) to open the Edit Objects Box. Locate the Textl database field. Type in the
correct number. Click Apply and then close the Edit Objects Box. When you are
finished assigning item number balloons. Your print should look similar to the
screenshot pictured below.

/@

Nane | il | T
Craatad By [0FE 1,/20,/04 .
By 755 730708 Symbol/gr?m Tuterial
[Bein
7'1'1'5'1':-: P Orirwnsy Nuriibar [
Nz immaml” | syn-001 | 1
R Fom +1 =211

Ha Changa Dats it Lt




Select the BOM Tool from the
BOM Tool Palette; the last tool
in the palette.

i |58

Move your cursor to the upper left
corner of the title block. The

Drafting Assistant should read
endpoint. Move the cursor
vertically upwards along the Y
A axis. The Drafting Assistant
should say Align Y. With

G Align Y still active, click a
——foh . i Point roughly 27-2.5 above
the title block. Voila! There

is now a nice BOM Table

on your print. Simply use

the Move tool and Expand /
Shrink tool to make the BOM
Table sit on top of the title

block at the right length. Your

Print should be similar to the
one shown at left.

A Quick Word About the Quantity Field : technically, the unit of measure for the “tubing”
in the drawing should be in feet and/or inches, or read A/R for “As Required”. It would be better to
alter the attribute type here to Text so “As Required” could be used. This was not done. The
primary focus is meant to demonstrate the concepts behind using the tools. If this type of function
is needed a set of different BOM attributes could be created on a different Layout.




CONGRATULATIONS!

This concludes the B.O.M. Tool, Symbols, and Graphite tutorial. The tutorial was prepared
and written by members of the Ashlar Technical Support team. Reproduction in whole or in part
of this document for commercial purposes is strictly prohibited without the express written
consent of Ashlar-Vellum, Inc.

Please direct any comments , questions, and/or concerns about this document to Ashlar
Technical Support.

Ashlar Technical Support
Toll-Free (Main) — 800-877-2745
Toll Free (Support) — 800-966-2348
e-mail — support@ashlar.com

Thank You!




