
Cube Tutorial                                                                                                 Ashlar-Vellum 1 

 

Introduction 

This tutorial describes how to use Ashlar-Vellum software to create a model of 
the Apple G4 Cube.  This is not intended to represent the idea that Apple used 
Ashlar-Vellum software to create the Cube (in fact, I have no clue what they 
used).  It is intended to provide documentation for the user to learn the tools 
provided in Ashlar-Vellum software to do product design.   

The complete tutorial covers close to 35 tools within the application as well as 
many concepts to help make your work more efficient.  At the end of each 
section you will be asked to save the file (which is just good practice to develop).  
At the beginning of the next section there will be a file available to download that 
represents the model up to that point.  If you get lost, or the tutorial gets 
complicated you can skip to the next tutorial and get the most recent file.  I don't 
recommend this, but it’s an option if you need to.  

This tutorial was created in Cobalt v5 using a 467mhz Dell with 512 mb of RAM 
(There is something a little funny about building a Mac on a PC, something about 
the irony.)  This model is built using inches for the units.  If your default units are 
millimeters, you may want to change them to inches in File>Preferences. 

Most of the tutorials are for creating the five different parts of the model, with the 
last tutorial dedicated to lighting and rendering.  So, without further adieu, lets get 
started. 
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Building the Outer Case 2 

Building the Outer Case 2 

 

Begin a new file and save the save the file (Cube01.co). 
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Select the Rectangle Tool.  

 

Select the “Polygon by Center and Point On” option.  

 

Create a square with the center at the origin.  

 

Type 7.75 for both the W and H fields (Width and Height).  

 

Select the Offset Curve tool.  
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Chain Select* the four sides of the square.   

*P.C - hold the Shift key while selecting the first line and afterwards, with the Shift key 
still held down press the ~ (tilde) key to automatically select all of the lines connected in 
the chain. 

Mac - you must hold the Shift key while you select the first line and press Command+~ 
(tilde), while holding the Shift key to select the lines connected in the chain. 

TIP: set the select chain keyboard shortcut to be "z". When shift is held down, pressing 
the "z" key will select the chain. 

 

Select inside the square to set the offset direction.  
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Type .125” into the offset field and press Enter.  

 

Chain select the outside square again and offset it .375” inward. 
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Select the Line tool.  

 

Draw a line from the midpoint of the leftmost line towards the origin of the 
drawing.  

 

Enter .875 for the L field (Length)  

 

Select the Select tool.  
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While holding CTRL on Windows (Option on Macintosh), select and drag a copy 
of the line to the other side of the square.  

 

Select the Parallel Line Tool.  

 

Drag the top most line downward from its current position.  
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Type 11/16” into the offset field and press Enter.  

 

Tip:  All numeric fields within Ashlar-Vellum software allow mathematical 
calculations. For instance, I don't know of hand that 5/64" =  0.078125, but if I just 
type in 5/64", it'll figure it out for me.   

Drag a line off the one you just created downward.  
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Type .5” into the offset field.  

 

Drag a line off the leftmost line inward 1”.  
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Drag a line off the rightmost line inward 1”.  

 

Select the 3-Entity Fillet  tool.  
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Select the 3 lines at the points shown below.  

 

Repeat this on the 3 lines at the other end as shown below.  
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Select the Mirror tool.  

 

Chain select the oval shape just created.  

 

While holding CTRL (Option on a Macintosh), click in the origin and then at a 
point to the left or right along the X-axis.  
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Select the Rectangle tool.  

Look at the message line to ensure that the "Polygon by Center and point on" 
option is selected.  

 

Select the origin for the center and create a rectangle "W= 4 13/16” L=2 1/2".  
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Select the 3-Entity Fillet tool and round the edges of the rectangle as we did 
earlier.  

 

Zoom in on the lower section of the drawing.  
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Select the Line tool.  

Draw a line from one edge of the oval shape to the other.  

 

Select the Parallel Line tool.  
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Drag a line downward from the line you just created 3/32”.  

 

Drag another line up from the original line "3/32".  
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Delete the original line.  

Select the Line tool.  

Draw a line at the points shown below.  

 

Select the Parallel Line tool.  

Drag a line off the one just created to the right 3/16”.  
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Repeat this process on the other end of the oval.  

 

Delete the two lines shown below.  

 

Select the 3-Entity Fillet tool.  

Round the ends of this as we have done before.  

 

Zoom Out to see the whole drawing.  

Save the File.  

Click below to proceed to the next step.  

Building the Outer Case 3  

Building the Outer Case 3  

Change to the Trimetric view. Ensure that the Work Plane snap is off.  
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Select the Move Tool.  

 

Select the outside square.  
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While holding CTRL (Option on Macintosh) move a copy of the square down 
along the Z-axis.  

 

Enter –9.75 into the dZ field (distance along the Z) and press Enter.  
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Move the next outermost square -9.75" without holding CTRL (Option on 
Macintosh).  

Move the innermost square down 5/16” without holding CTRL (Option on 
Macintosh) .  

 

Select the Ruled Surface tool.  

 

Switch to Shaded Mode.  

Open the Select Mask(Window>Select Mask) and highlight only “Lines”.  

Tip: The select mask is a tool implemented to make selecting objects faster.  
Once you get a complicated model created, you may have 1000's of entities in 
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your model.  Selecting them can get difficult when there are 4 or 5 entities 
overlapping each other.  In this case, we are about to create many surfaces, 
since Ashlar-Vellum software allows the user to select surface edges as defining 
geometry, selecting the lines that also happen to lie in place with the surface 
edges will bring up an ambiguity box asking you which object to select.  With the 
select mask set as shown, the program will only select the lines in the model.  

 

Select the edges as shown below to create surfaces for the sidewalls of the 
outside and the inside of the outer case.(There will be 8 of these total)  

Tip: It may help to rotate the view to help select the correct edges.  

 

Change back to Trimetric view.  

Select the Cover Surface tool.  
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Switch back to wireframe mode to make it easier to select the lines.  

Make a cover surface for the top of the model.  

 

Make another from the innermost square.  
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Create another surface form the bottom outermost square.  

 

Select the Split Surface tool.  



Cube Tutorial                                                                                                 Ashlar-Vellum 25

 

Select the bottom surface you just created.  

 

Select the inside square at the bottom of the case.  
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You should now have 6 surfaces  

a. 2 Skinned Surfaces (Outside and Inside Walls)  
b. 1 Cover Surface  (The top)  
c. 1 Cover Surface  (The middle)  
d. 2 Surface Faces (Created from the bottom cover surface that was 

split.)  

Open the Object Counts dialog from the Verify Menu.  Look to ensure that you 
do in fact have just 6 surfaces.  



Cube Tutorial                                                                                                 Ashlar-Vellum 27

 

 

Close the Object Counts dialog.  

Select the inside surface of the surface we split and delete it.  



Cube Tutorial                                                                                                 Ashlar-Vellum 28

 

Select the Stitch Solid tool.  

 

Draw a selection box over all surfaces to stitch them together into a solid.  If the 
select mask is open, ensure that all types of objects can be selected.  
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Select the Cutout Feature tool.  

 

Select the "Stitch" Solid.  

 

Chain Select the oval towards the rear of the model.  
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Make sure the Work Plane Snap is unchecked.  Select one point is space then a 
second point down in the Z-direction to define the direction of the cutout.  
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Repeat this procedure with the same solid outer case and the oval shape in the 
middle of the model.  This time, after you define the direction of the cutout, 
change the value in the Draft Angle field to –30.  

 

Zoom in on the other two oval shapes near the front of the model.  
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Select the Move tool.  

 

Chain Select the inside oval shape.  

Move it down "5/16" in the Z-direction.  

 

Select the Skinned Solid tool.  

 

Select the two oval shapes for the profiles. 
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Select the Subtract Solid tool.  

 

Select the large outer case first, then select the smaller section (the skinned 
solid) we just created.  

Select shaded mode to see the results better. 
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Zoom All.  

Right Click (Option-Click on Macintosh) on the case and select Transparency.  

 

Save your file.  
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Click below to proceed to the next step.  

Building the Outer Case 4  

Creating the Outer Case 4  

Switch back to wireframe.  

Select the Radial Blend Tool and set the R (radius) value to .75.  

 

Select the four outside corner edges and the four inside corner edges to blend 
them (One at a time or all 8 edges at once.)  

 

Zoom in on the top face.  
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Select the Hole tool.  

 

Select the Counter bore option and Through for the depth.  

Set the fields to the following: (We don't have to worry about the first "Depth" field 
since we set the option in the message window to "Through".)  

Diameter = 1/4"   
Draft Angle = 2"    
Counter bore Diameter = 13/32”     
Depth = 1/8”  
Select the top face of the case.  
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Select the endpoint of the line as shown 

below.   

Repeat this for the endpoint of the other line to create another hole.  

 

Switch to the Back View and Zoom All.   

Turn the Work Plane snap ON.  

Select the Rectangle Tool.  

Draw a rectangle with the center at the midpoint of the bottom of the case. W = 5 
5/16”  L = 4 5/16  
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Switch to Trimetric View.  

Turn the Work Plane snap OFF.  

Select the Extrude Solid tool.  

 

Select the Rectangle that was just created.  
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Extrude the rectangle back along the Y-Axis.  

 

Select the Radial Blend tool and set the Radius to 1.25”.  
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Select the top two edges of the block.  

 

Select the Subtract Solid tool.  

 

Select the case first then the blended block.  

Zoom in on the lower area of the outer case and select the Radial Blend tool 
again and set the Radius to .125”.  

Select the bottom edges of the case to blend them.  
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Zoom all.  

Select the case with the Select Tool and select Show Only from the Show-Hide 
Palette.  

Switch to shaded mode.  

 



Cube Tutorial                                                                                                 Ashlar-Vellum 42

Save the file.  

This completes the modeling of the outer case.   

 

Using the Layer Manager and Building the Posts 

Posts 

This small section describes how to create the aluminum posts on the top of the 
model.  We have already made room for them when we built the outside case. 

Now seems a good time to discuss better organization of our model.  Ashlar-
Vellum provides the user with layers in which to organize their work.  These 
layers are all controlled through the layer manager.  With the Layer Manager the 
user can create, edit, move and perform many other functions to layers within the 
model.   

Open the Layer Manager by selecting Layout>Layer Manager.  

You will notice that the layer named "Layer 1" has a small pencil icon next to it.  
This is the indication that "Layer 1" is the current layer.  While "Layer 1" is 
current, all geometry created is put on Layer 1.  Since we are beginning a new 
part to our model it is a good time to make a new layer for it to go one.  (Putting 
separate parts on different layers is by no means mandatory, but it does make 
the model drastically easier to manage.)   

Select the "Create a new Layer" icon. 

Right-click (Option-Click) on the new layer (Layer 2) and select Rename. 

Rename the layer to "Posts." 

Rename "Layer 1" to "Outside Case." 

Make the "Posts" layer current by clicking in the leftmost box. 

That is all that we need so with Layer Manager for awhile so we can just close it 
to free up space on the screen.   

Building the Posts 

Building the Posts  
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Zoom in on the hole on the left side of the case and ensure that the Work Plane 
snap is off.  

 

Select the Cylinder Primitive tool.  Enter 3/8” for the D field (Diameter).  
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Select the center of the top of the counter bore for the start of the cylinder and 
the center of the bottom of the counter bore for the 

end.   

Create another cylinder with the same start point and place the endpoint at 
center of the bottom of the hole.  

Change the diameter to 7/32"  

 

Select the Union Solid tool.  

 

Union the two cylinders.  
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Go to the Top View and Zoom All and turn the Work Plane snap on  

 

Select the Select Tool.   

Select the post you just created and drag a copy of it to the center of the other 
hole.  
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Save your file.  

 

Creating the Inside Case  

 Building the Inside Case 

This section describes how to create the inside case of the model.  To do this, we 
will use one of the many advantages of the Ashlar-Vellum modeling 
environment.  All geometry and all parts within the model are created in the same 
window.  There isn't a separate part and assembly mode.  This makes it very 
easy to reference geometry on existing parts.   

From time to time, we will be referencing and building new geometry based on 
the outer case.  Even though we need the outer case available, we do not 
necessarily want the case around all the time.  A solution could be to use the 
outer case when we need then open the layer manager, turn off the the outer 
case layer then close the layer manager to get it out of the way.  Luckily, Ashlar-
Vellum Software has provided a much more efficient solution, the Show-Hide 
Palette. 

The Show-Hide palette allows the user to quickly hide individual objects 
temporarily.  Moreover, it takes up minimal space on the screen so that it can be 
left open. 

Click below to proceed to then next step. 

Building the Inner Case 

Building the Inside Case 

Since we will be once again creating a new part to our model, we will create a 
new layer for it to be put on. 

Open Layer Manager. 

Create a New Layer.  Rename it "Inside Case", make it current and turn off the 
"Posts" Layer.  
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Close the Layer Manager.  

Go to the Trimetric View.  

Select the Explode Edge tool.  

 

While holding Shift, explode the inside edges of the bottom of the Top section of 
the case as shown below.  
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Select Extrude Solid tool.  

 

Select the exploded lines and extrude them down 7”.  
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Hide the Outer Case.  

Select the Shell Solid tool.  

 

Set the Offset value to 1/16” and select the Extrusion.  
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Select the bottom face to be open.  

 

Show the outer case.  

Select the Explode Edge tool.  
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Zoom in and explode the edges shown below.  

 

Hide the Outer Case.  

Select the Cutout Feature Tool.  

 

Select the inner case. 



Cube Tutorial                                                                                                 Ashlar-Vellum 52

  

Select the edges you just exploded.  

 

Choose a point in space and another point down along the Z-axis.  
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Click below to proceed to the next step.  

Building the Inside Case 2  

Building the Inside Case 2  

Go to the Top View.  

Select Show from the Show-Hide Palette.  

Select the lines and arcs that make up the oval towards the top of the screen.  
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Zoom in on the upper oval.  

Select the Line Tool and turn on Work Plane snap.  

 

Create a line from the left quadrant to the right 3/32”.  
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Draw a line from the endpoint of that line up 5/32”.  

 

Draw a line from the endpoint of that line to the right 3/32”.  
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Select the circle tool.  

Create two circles with diameter 1/8” at the points shown below.  

 

Mirror a copy of the top circle to the other side.  
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Select the Select Tool.  

Select the three circles.  

Select the Linear Duplicate tool.  

 

Fill in the values in the window as shown below and select OK.  
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Delete the two circles that extend beyond the oval.  

 

Delete the small lines that you created.  
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Hide the oval shape. 

  

Go to the Trimetric View and Zoom in on the circles. 
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Select the Cutout Feature Tool and turn off the Work Plane.  

 

Select the inside case.  
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Select all of the circles that were created.    

Note:  Be sure not to have circles on top of each other, otherwise, this function 
will not, work.  If you receive an error, check to make sure you do not have 
circles over lapping each other.  

Select a point in space and then another point down along the Z-axis.  
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Show the outer case and turn on the posts layer.  

Zoom all.  

Shade the view.  
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Save the File.  

Click below to proceed to the next step. 

Creating the Grill 

The Grill 

Open the Layer Manager.  

Create a New Layer, Rename it  “Grill” and make it current.  

Turn off layers “Posts” and “Inner Case”.  

 

Close the Layer Manager.  

Select the Explode Edge Tool.  

 

Explode the edges shown below.  
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Select the Extrude Solid tool.  

 

Select the exploded geometry the was just created.  

Extrude them down 5/16” down the Z-axis.  
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Select the Subtract Solid tool.  

 

Select the Extrusion that was just created.  

While holding CTRL (Option on a Macintosh), select the outer case.  
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Hide the outer case.  

Select the Extrude Solid tool.  

 

Select the bottom face of the solid.  



Cube Tutorial                                                                                                 Ashlar-Vellum 67

 

Extrude the face down .75” in the Z-direction.  

 

Select the Union Solid Tool.  
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Select the two solids in the Drawing Window.  

 

Select the Select Tool.  

Select the “Union” Solid just created, Copy it and Paste it in its same location.  

Select the Shell Solid Tool.  

 

Set the Offset value to .125 and select the “Union” to shell it.  

While holding Shift, select the top and bottom faces of the “Union” to be open.  
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Hide the “Shell” solid that was recently created.  

 

Save your file.  

Click below to proceed to the next step.  

Building the Grill 2  

Building the Grill 2  

Go to the Top View and turn the Work Plane snap on.  

Select the Rectangle Tool.  Set the creation option to “Polygon by Center and 
point on.”    



Cube Tutorial                                                                                                 Ashlar-Vellum 70

 

Create a rectangle with the center at the origin W = 3/32” H = 3”.  

 

Go to the Trimetric view and turn the Work Plane snap off.  

Select the Extrude Solid Tool.  
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Select the rectangle and extrude it down 1 1/16”.  

 

Go to the Top view and turn of the Work Plane snap.  

Select the Linear Duplicate tool.  

 

Select the “Extrude”.  

Set the values in the linear duplicate dialog as shown below.  



Cube Tutorial                                                                                                 Ashlar-Vellum 72

 

Repeat this procedure, but change the Dx value to –2”.  

 

Select the Rectangle tool.  

Select the “Polygon by diagonals” option.  
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Create a rectangle at the points shown below.  

 

Go to the Trimetric view.  

Select the Extrude Solid tool.  
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Extrude this rectangle down 1 

1/16”.   

Select the Union Solid Tool.  
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Select the recently created “Extrude” for the solid to add 

too.   

While holding Shift, select the other narrow blocks to union them together to the 

“Extrude.”   

Select the Intersect Solid tool.  
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Select the two solids in the drawing area to intersect them. 

  

Show the “Shell” Solid that was hidden earlier.  

Select the Union Solid tool.  
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Union the “Shell” solid with the “Intersect” 

solid.   

Show only the new “Union” solid.  

Turn on all of the layers, Zoom all and shade the 

view.   

Save your file.  
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Click here to proceed to the next section.  

Creating the apple  

Creating the Apple 

This section describes using geometry imported from another program to create 
solids withing our model.  In this particular case, we will be using an Illustrator 
file.   

Note: When importing Illustrator files, ensure that the file is in a Version 8 format, 
otherwise it may not import properly. 

Go to the Top View. 

Import the file “apple.ai” by selecting File>Import.   Set the import type to Adobe 
Illustrator and set the options as shown below.  

 

Select OK.  Locate and open the file "apple.ai."  

Select the Select Tool.  

Select the imported geometry.  
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Select Edit>Change Resolution.  

Set Resolution to Super Fine.  

 

This will only change the resolution of the selected geometry.  In order to change 
the resolution for all geometry that will be created, it is necessary to change the 
settings in the preferences.   

Choose File>Preferences.  

In the Display Category, change all types to Super Fine.  
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Open the Layer Manager.  

An imported Illustrator file gets imported into its own new layer.  

Rename Layer 1 to “Apple” and make it current.  

Turn off layers “Posts”, “Inside Case” and “Grill.”  
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Close Layer Manager.  

Go the Trimetric View.  

Select the Rotate Tool.  

 

Select the “Rotate by angle option” and about the X-axis.  

 

Enter 90 into the Angle field.  

 

Select a point on the apple geometry.  
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Go to the Top view and turn on the Work Plane snap.  

Select the Move Tool.  

Move the apple geometry to the front of the outer case.  
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Go to the Front view.  

Select the Line Tool.  

 

Draw a line as shown below.  
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Select the Point tool.  

 

Place a point at the midpoint of the line  
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Select the Line tool.  

 

Draw another line as shown below.  
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Select the apple geometry.  

 

Select the Move tool.  
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Select the point in the middle of the apple geometry for the first reference point 
and the midpoint of the long line for the second point.  
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Delete both of the two lines that were previously created.  

Click below to proceed to the next step.  

Creating the Apple 2  

 

Go to the Trimetric view.  

Select the Extrude Solid tool.  

 

Select the main body of the Apple.  
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Extrude this geometry back 1/16”.  

 

Repeat this for the smaller portion of the apple.  
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Select the Subtract Solid tool.  

 

Select the outer case and while holding CTRL (Option on a Macintosh), select 
the main body of the apple.  
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Repeat the extrude and subtract procedure for the smaller portion of the apple 
geometry.  

 

Hide the outer case.  
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Select the Select Tool.  

Select the main body of the apple extrusion.  

Go to Window>Edit Objects.  

Under the Display tab set the U and V both to 4.  
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Select the Deform Face tool.  

 

Select the Inflate/Deflate option and Change the Gain to 50.  

 

Select the front face of the main part of the apple extrusion.  
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Go to the Side view and zoom in on the apple extrusions.  

 

If not already open, re-open the Edit Objects dialog and select the Geometry 
tab.  
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Set the values as shown below.  

 

Go to the Trimetric view and set the U and V of the part back to 0.  

 

Zoom in on the smaller portion of the apple extrusion.  

Select the Line tool.  
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Draw a line from one corner of the front face to the other corner of the front face.  

 

Create another line for the midpoint of the new line out along the Y-axis 1/16”.  
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Select the 3-Point Arc tool.  

 

Create a 3-Point Arc at the 3 points shown below. 
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Create another 3-Point Arc as shown below.  
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Select the Point tool.  

 

Place points at the two corners of the front face as shown.  

 

Select the Net Surface tool.  

 

Select the geometry as shown below.  
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Select the Replace Face tool.  

 

Select the front face of the smaller portion of the apple extrusion.  
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Select the " Net Surface".  

 

Open the Layer Manager.  

Turn on all Layers.  
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Select Show All from the Show-Hide palette.  

 

Zoom All.  

Open the Select Mask.  

 

Highlight only Solids in the Type Field.  

Double-Click on the Select Tool to Select All.  

Select Show Only from the Show-Hide palette.  
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Shade the view.  

 

Save the File.  

This is the last section concerning modeling our cube.  The rest of our tutorial 
focuses on applying materials to the parts in our model and setting up scene with 
lighting and rendering a final image.  

Click below to proceed to the next section.  

Materials, Lighting, and Rendering  

Lighting and Rendering 

This last section brings our model together to create a rendered image.  This is a 
power of Ashlar-Vellum software that can be pulled together with a model to 
create a very powerful presentation piece to sell your idea or reassure our client 
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that they chose the right designer for the job.  In contrast, a poorly rendered 
image can hurt your idea just as a good one can sell it.  The basics of rendering 
that are most important to the final image are materials, lighting, scene, and 
perspective. 

These attributes alone can make a noticeable difference in the final image, but 
pieced together can create create a surprising realistic and effective piece (I think 
its that whole Gestalt thing making that happen.)   

The best way to see the power of what can be done is to see it before and see it 
after.  So to begin with, lets render the current view to see how it looks right now. 

Render the Current View.  PhotoRender>Preview no shadows. 
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Not too impressive.  It basically looks like a big block of nothing.  Well, we are 
about to change all of that. 

There are many ways to set the material of an object in your model.  The first 
(and easiest) is to select a pre-built material from the Render Library provided 
by the Ashlar-Vellum software. 

Select the Outside Case.  

 

Open the Render Library.  
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Select “Materials” and “Glass” from the drop-down menus.  

 

Right-Click (Option-Click on a Macintosh) on the “Glass.Clear” material and 
select “Apply Material to selected object.”  

 

That's all there is to it.  Select what you want, and put in on there.  Even though 
Ashlar-Vellum software provides a great variety of materials, it is often times 
necessary to make something a little more custom.  One way to accomplish this 
is to create a material from scratch. 

Click below to proceed to the next step. 

Lighting and Rendering 2 

Lighting and Rendering 2  

Turn off the “Outside Case” layer. 

Zoom in on the Grill.  

Select the Grill  
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Open the Edit Objects dialog.  

Under the Material tab uncheck “Use Object Color” and select Apply.  The 
settings provided under the material tab in the Edit Objects dialog are very good 
for piecing together a very quick material.  But in order to take advantage of all 
that the rendering within Ashlar-Vellum software has to offer, it is necessary to 
get into the advanced Render Material Settings.    

Select “Advanced.” 
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Look at the dialog.  

It uses 5 main properties (shown in the Shader Class.)  

 

First, select the Color shader type.  
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Leave the Shader Type as plain and set the attribute to Gray 92.  You could also 
just type the RGB values in to their respective fields (235,235,235.)  

Select Update under the thumbnail preview.  

Go to Displacement.  

 

Set it to None.  

Update Preview.  

Select Reflectance.    
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From the best I can tell the grill piece on the actual computer is metal.  I for one 
would like to thank them for making the piece from actual metal.  Too many times 
in design and production, I have seen products made from plastic that imitates 
metal or some composite material such as carbon fiber.  This only gives a feel of 
lack of quality in any such product.  I understand that it could have been a cost 
reduction or some other factor that led to the decision to make the product out of 
some imposter material, but that decision robs the product of its experience.  
One of the many beauties of metal is that it is indeed metal.  Its malleability, its 
conductivity, the way it holds heat as well as retains its coolness. its tactile 
interaction with the hand.  These are things that plastic cannot replace.  Don’t 
mistake me; I'm not anti-plastic, merely pro-metal.  I strongly believe there is a 
place for plastic.  It has many qualities itself the metal cannot imitate or replace.  
But the place for plastic is definitely not to replace and mock the good name of 
metal. 

 

Let me step from my pulpit so that we can get back to why you are here.  As I 
previously stated the grill on the actual computer is metal.  But what we are 
attempting here is to give the appearance of metal.  As this may contradict my 
small sermon, remember that this is just a rendering not the actual piece.  The 
setting we choose here is intended to give the soft reflection of the piece in the 
real world.  The Metal setting, (which seems to make sense for this piece) gives 
a very hard highlight and a bit of a mirror reflection on the piece.  The Plastic 
Shader type is much softer and more appropriate for this piece.  Set the Shader 
Type to Plastic.  

Set the values as following:  

a. Ambient Factor   1.25  
b. Diffuse Factor    1.0  
c. Specular Factor  1.0  
d. Rough    0  
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e. Specular Color-  SGI Light Blue. (This will make the highlight a 
softer cooler color and feel.)\  

Select Update to see how our changes have affected our piece. 

 

Select OK to close the Render Material Settings dialog with our changes.  

Select Apply in the Edit Objects Dialog.  

We will create another material from scratch to apply to the Inside Case.  

Select  the Inside Case. 

Deselect “Use Object Color” in the Edit Objects dialog and select Apply.  

Go into the advanced Render Material Settings for this object.  

Select the color as Gray 92.  

Set the Displacement to None.  

Set the Reflectance to Phong and use the following values for the Attributes.  

a. Ambient Factor  1.5  
b. Diffuse Factor  .75  
c. Specular Factor  .85  
d. Exponent   10(Default)  
e. Specular color  (Default)  

Select OK in the Render Material Settings dialog.  
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Click below to proceed to the next step. 

Lighting and Rendering 3 

Lighting and Rendering 3 

Yet another way to get a material for apart just like we want it is to apply and edit 
an existing material provided from the Ashlar-Vellum software.  At some point 
you may see a material in the Render Library that is very close to the effect that 
you are trying to achieve.  For instance, you like the way it reflects, you just need 
it be a different color.  Next we will set a render library and adjust certain 
attributes to achieve the effect we need. 

Hide the “Inside Case” and “Grill” layer.  

Zoom in on the leftmost post.  

Select the Select Tool.  

Select the Post.  

 

Select “Metal” from the drop-down list in the Render Library.  

Drag the material “Metal.Aluminum(L.Brushed)” to the post.  
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Open the Render Material Settings for this object and go to the “TextureSpace” 
Shader Type.  

 

Select the center point Attribute.  

 

Select the center of the top face of the post.  



Cube Tutorial                                                                                                 Ashlar-Vellum 114 

 

Select Update.  By changing this attribute we are able to give the effect of the 
spun aluminum that the actual piece.  

 

Zoom in on the other post and repeat this procedure.  

Hide the “Posts” Layer.  

Zoom all.  
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Select the main part of the Apple.  

In the Render Library, set the material to “Glass”  

 

Apply the “Glass.Colored” material to the main part of the apple.  

 

In the Edit Objects dialog, deselect “Use Object Color” and select Apply.  
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Change the Color to SGI Light Blue and Select OK.  

 

Repeat this for the Smaller portion of the Apple.  

Turn on all Layers.  

Zoom All.  

Select Window>Hide all tools.  
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Select PhotoRender>Raytrace Render [shadows on, anti-alias].  

\ 
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This definitely makes a noticeable difference in out model.  Although not 
complete, the materials do help our image.  The next part of the process 
concerns setting up the scene with lighting and other objects to complete the 
image.   

Lighting and Rendering 4 

Show all tools.  

Create a new layer, rename it “Scene” and make it current.  
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Close the Layer Manager.  

The first part of our scene will be a floor that the model sits on.  This will give it 
shadows from the lighting and something in the environment for the model to 
reflect off of. 

Close the Render Library and Edit Objects Dialog.  

Go to the Top view.  

Turn on the Work Plane Snap.  

Zoom way out on the model.  
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Select the rectangle tool.  

 

Create a rectangle from one corner of the drawing area to the other.  
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Select the Cover Surface tool.  

 

Create a cover surface from the rectangle.  

Go to the Right Side view.  

Zoom out enough so that you can see all of the outside case. As you can see, 
right now our floor is above our model.  This will not be a good thing for the 
rendering, so we need to move it down.  
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Select the Move Tool.  

 

Select the Cover Surface. 
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Move the surface to the bottom of the outer case.  
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Hide the lines that make up the rectangle.  

This completes our floor.  This is about as simple as environment objects can get 
for setting up a scene, but it is quite amazing how much difference something so 
simple can make with an object such as this.  A simple studio scene like this fits 
quite well with the content.  It's clean and simple, something I believe the 
company who makes this product tends to carry out with many of their products 
and imaging.   

Go to the Top view.  

Zoom in a little on the model.  

 

Open the Lights tool palette.  
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Select the Point Light Tool.  

 

Place three lights close to shown below.  

 

Select the Select tool.  

Go to the Right Side view and move the lights up a little.  
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Select all three lights and open the Edit Objects dialog.  

Change the shadow type to “Soft” and the Intensity to .45.  

 

Go to Trimetric View.  

Zoom all.  
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Select the " Cover Surface" (the Floor).  

Deselect “Use Object Color” and open the advanced Render Material Settings.  

Change the Color to “Gray 96”  

Zoom in on the Main model.  

Render the View.  

 

This image really seems to be coming together now.   The last piece of the 
puzzle is the perspective and the view.  These attributes can add a sense of 
scale to the rendering as well as dramatic effects.  Giving a rendering of a car 
some extreme perspective can give it a sense of speed and power.  This final 
aspect it what makes a rendering not look like it came from an MCAD software 
package.  It adds more art to the engineering, allowing the user to give an 
emotion to an image as well as communicate information.  

There is no one set standard on how to provide the proper perspective or view.  It 
is a matter of opinion and a lot of trial and error to get it set the way you desire.  I 
can however inform you of the tools we provide to do it.   
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The view can be rotated with the Trackball. 

Perspective is toggled on or off with the icon at the right of the view palette.   

 

You can double-click on this icon to open a Modify View dialog to allow the user 
to numerically alter the perspective as well as the view. 

 

Save your file.  

Set the view how you would like it and select PhotoRender>Raytrace Render 
[no shadows, anti-alias], or if you would like to save the rendering select 
Render to File.  
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This completes this tutorial.  You have now covered over 30 tools within the 
Ashlar-Vellum software, as well as concepts to help you efficiently create 
geometry, manage your model and produce quality renderings with future 
projects that you work on.   

Congratulations and Good Luck. 

 

 

 

 

 

 

Tutorial by Nathan Mitchell 12/30/2002 
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